Configuração manual de Mikrotik com mais de um hotspot

Objetivo

Este tutorial tem como objetivo configurar equipamentos Mikrotik manualmente com mais de um hotspot, para funcionar com a Mambo

Pré-requisitos

Possuir um cabo conectado na porta 2 do Mikrotik
Possuir internet configurada no Mikrotik

Possuir o Winbox no computador


Configuração da Rede


Para o procedimento, vamos utilizar como exemplo duas interfaces: bridge-hotspot e bridge-hotspot2, cada uma com uma rede específica que será aplicado o hotspot redirecionando para o Captive Portal da Mambo.



Para começar a configuração, acesse o Mikrotik através do programa Winbox, como na imagem abaixo:



Acesse o menu lateral, e clique em Bridge 


Selecione o botão + e crie uma bridge como no exemplo abaixo, finalize com o botão Apply 


Repita o mesmo processo para a segunda interface bridge, seguindo o exemplo com o nome bridge-hotspot2


Agora vá para Ip-> Address selecione o botão + e adicione uma rede a cada interface bridge criada anteriormente, como no exemplo abaixo:



Com as redes definidas, atribua as interfaces que farão parte da bridge, podendo ser uma interface ether, vlan ou wlan, nesse exemplo serão atribuídas as interfaces wlan;



Para criação do hotspot, as configurações acima podem ser ignoradas caso já tenha redes definidas no Mikrotik. Vamos utilizar o setup do Mikrotik para isso, acesse o menu lateral e clique em New Terminal. 

Digite o comando /ip hotspot setup logo abaixo, digite a interface que será aplicado o hotspot.

A partir desse passo, basta confirmar cada interação com o botão enter, seguindo o exemplo abaixo:



Para o exemplo acima, foi adicionado um masquerade para a rede criada e também endereços de DNS, caso não precise, basta colocar "no" ao invés de "yes" na solicitação do masquerade network e deixar em branco o campo de dns servers.


Configuração Do Hotspot


Com o hotspot criado, acesse as configurações através do menu lateral em Ip -> Hotspot. Acesse a aba Servers e coloque como Name o mesmo do Identificador do painel,administrativo para mais detalhes consulte esse artigo identificador



Seguindo a configuração, abra a aba Server Profile, em General selecione a pasta html a qual pertencerá esse profile e na aba Login, marque as opções como no exemplo abaixo:


 IMPORTANTE! Para o passo do Radius, vamos aplicar um identificador de domínio para diferenciar esse hotspot, nesse exemplo foi aplicado um alias no campo Default Domain "hotspot1".Mas a frente, esse mesmo Domain será referenciado no tópico Configuração de Radius.

.

Aplique a configuração e siga para a aba user profile, deixando as configurações como no exemplo abaixo;


Aplique a configuração e novamente no terminal, digite o comando para inclusão dos domínios no Walled Garden


/ip hotspot walled-garden
add dst-host=*mambowifi*
#facebook
add dst-host=*facebook.com*
add dst-host=*akamai*
add dst-host=*facebook.net*
add dst-host=*fbcdn.net*
#twitter
add dst-host=*twitter*
add dst-host=*twimg*
add dst-host=*fastly.net*
add dst-host=*edgecastcdn.net*
#instagram

add dst-host=*instagram.com*
add dst-host=*doubleclick.net*
add dst-host=www.google.com
add dst-host=www.google.com.br


/ip firewall address-list add address=uploads.mambowifi.com list=mambo

/ip firewall address-list add address=mambowifi.com list=mambo

/ip firewall address-list add address=facebook.com list=facebook

/ip firewall address-list add address=facebook.net list=facebook

/ip firewall address-list add address=akamaihd.net list=facebook

/ip firewall address-list add address=fbcdn.net list=facebook

/ip firewall address-list add address=www.googleapis.com list=google

/ip firewall address-list add address=ssl.gstatic.com list=google

/ip firewall address-list add address=fonts.gstatic.com list=google

/ip firewall address-list add address=www.gstatic.com list=google

/ip firewall address-list add address=accounts.google.com list=google

/ip firewall address-list add address=accounts.youtube.com list=google

/ip firewall address-list add address=accounts.google.com.br list=google

/ip firewall address-list add address=gstatic.com list=google

/ip firewall address-list add address=twitter.com list=twitter

/ip firewall address-list add address=twimg.com list=twitter

/ip firewall address-list add address=abs.twitter.com list=twitter

/ip hotspot walled-garden ip add dst-address-list=mambo

/ip hotspot walled-garden ip add dst-address-list=facebook

/ip hotspot walled-garden ip add dst-address-list=google

/ip hotspot walled-garden ip add dst-address-list=twitter

Lembrando que caso queira colocar as redes sociais, o usuário terá acesso aos domínios listados, mesmo sem a autorização no hotspot.


Baixe o arquivo de configuração no painel conforme esse artigo Cadastro de Ponto de acesso. Extraia os arquivos baixados do respectivo ponto de acesso, copie, selecione a pasta hotspot e cole no FIle List, pelo botão 'Paste ' ou arraste os arquivos até a pasta, conforme a imagem abaixo:



Configuração do Radius


Agora para criar o Servidor Radius, acesse através do menu lateral Radius, clique no botão + e insira as configurações. No campo Domain, insira o nome configurado no server profile,  como no exemplo abaixo:


Repita esse passo e crie outro Servidor Radius para o endereço 168.138.226.107. Para mais detalhes acerca desse procedimento consulte o passo 24 e passo 25 desse artigo Configuração Manual do Hotspot 




 Configuração do segundo Hotspot


Agora para configuração do segundo hotspot, repita os procedimentos demonstrados nos tópicos; Configuração de Hotspot e Configuração de Radius, aplicando as seguintes alterações:


Crie o hotspot em uma outra interface, no exemplo desse artigo, o segundo hotspot será criado na bridge-hotspot2

Em Server Profile, crie um novo HTML Directory, para isso, basta inserir um nome e clicar em Apply. Será criada uma pasta com o mesmo nome em File List.

Vá em File List, insira o arquivo baixado, alogin.html e login.html na nova  pasta criada, nesse exemplo será a pasta "hotspot2".

IMPORTANTE! Caso a pasta não seja criada com o procedimento acima, baixe a pasta existente do hotspot presente no diretório File List, renomeie e insira novamente a pasta com o nome alterado. Deverá aparecer a outra pasta hotspot, para esse caso, selecione o arquivo renomeado em HTML Direcetory na aba Server Profile e aplique a alteração.


Na aba Radius, repita o procedimento referenciando um novo domain, nesse exemplo será hotspot2.


Agora repita o procedimento demonstrado no tópico 'Configuração de Radius', tendo como única alteração, a inserção do mesmo nome configurado no Default Domain do Server Profile. Abaixo o exemplo:



Para criação de demais servidores hotspot e pontos de acessos, basta repetir esse procedimento. Qualquer dúvida ou auxílio, entre com contato com o nosso suporte pelo e-mail suporte@mambowifi.com