Objetivo

Este tutorial tem como objetivo configurar equipamentos Mikrotik manualmente para funcionar com o Mambo WiFi.

ATENÇÃO: O hotspot, no momento, é incompatível com a versão 7 (e superiores) do RouterOS por conta de um problema que existe nesta versão.



Pré-requisitos

Possuir um cabo conectado na porta 2 do Mikrotik
Possuir internet configurada no Mikrotik

Possuir o Winbox no computador

Configuração



1- Abra o Winbox e conecte ao Mikrotik


2- Vá até Bridge e clique no + para criar uma nova bridge


3- Dê o nome de bridge-com-hotspot para essa bridge (Para podermos identifica-la facilmente) e dê OK


4- Vá até System > Identity e copie o nome do identificador do seu Mikrotik, pois iremos utilizar em outros lugares


5- Vá até IP > Hotspot e clique no + para criar um novo servidor de hotspot


6- Coloque o mesmo nome do Identity que você copiou no passo 4 e selecione a bridge que você criou no passo 3 e dê OK


7- Vá até a aba Server Profile 


8- Clique duas vezes para editar o Default, vá até a aba Login e selecione os campos HTTP PAP e MAC Cookie


9- Vá até a aba RADIUS, selecione Use RADIUS, MAC Format separado por -, Interim Update 00:15:00 e dê OK


10- Vá até a aba User Profiles


11- Clique duas vezes no Default, preencha Idle Timeout com 00:15:00, Keepalive 00:15:00 e dê OK


12- Vá até New Terminal e cole os comandos abaixo (linha por linha):


/ip hotspot walled-garden
add dst-host=*mambowifi*
#facebook
add dst-host=*facebook.com*
add dst-host=*akamai*
add dst-host=*facebook.net*
add dst-host=*fbcdn.net*
#twitter
add dst-host=*twitter*
add dst-host=*twimg*
add dst-host=*fastly.net*
add dst-host=*edgecastcdn.net*
#instagram

add dst-host=*instagram.com*
add dst-host=*doubleclick.net*
add dst-host=www.google.com
add dst-host=www.google.com.br


/ip firewall address-list add address=uploads.mambowifi.com list=mambo

/ip firewall address-list add address=mambowifi.com list=mambo

/ip firewall address-list add address=facebook.com list=facebook

/ip firewall address-list add address=facebook.net list=facebook

/ip firewall address-list add address=akamaihd.net list=facebook

/ip firewall address-list add address=fbcdn.net list=facebook

/ip firewall address-list add address=www.googleapis.com list=google

/ip firewall address-list add address=ssl.gstatic.com list=google

/ip firewall address-list add address=fonts.gstatic.com list=google

/ip firewall address-list add address=www.gstatic.com list=google

/ip firewall address-list add address=accounts.google.com list=google

/ip firewall address-list add address=accounts.youtube.com list=google

/ip firewall address-list add address=accounts.google.com.br list=google

/ip firewall address-list add address=gstatic.com list=google

/ip firewall address-list add address=twitter.com list=twitter

/ip firewall address-list add address=twimg.com list=twitter

/ip firewall address-list add address=abs.twitter.com list=twitter

/ip hotspot walled-garden ip add dst-address-list=mambo

/ip hotspot walled-garden ip add dst-address-list=facebook

/ip hotspot walled-garden ip add dst-address-list=google

/ip hotspot walled-garden ip add dst-address-list=twitter


Atenção, os próximos passos podem ser ignorados ou então feito conforme as configurações da sua rede.  Se não tiver conhecimento sobre redes, sugerimos continuar seguindo o passo a passo.


13- Vá até IP > Pool e clique no + para criar uma nova pool


14- Coloque o nome de pool-com-hotspot (para facilitar a identificação), em Address preencha com 10.97.0.2-10.97.15.254 e dê OK


15- Vá até IP > DHCP Server e clique no + para criar um novo servidor


16- Coloque o nome de dhcp-com-hotspot, selecione a bridge que você criou no passo 3, lease time deixe 00:30:00 e Address Pool selecione a que você criou no passo 14. 


17- Vá até a aba Networks e clique no + para declarar a rede que você irá utilizar no DHCP


18- Coloque em Address 10.97.0.0/20, em Gateway 10.97.0.1, em DNS Servers 8.8.8.8 e dê OK.


19- Vá até IP > Addresses e clique no + para declarar a rede que você vai utilizar


20- Em Address coloque 10.97.0.1/20, em Network 10.97.0.0, e na interface selecione a bridge que você criou no passo 3


21- Vá até Bridge novamente, entre na aba Ports e clique no + para adicionar a interface em que você vai aplicar o hotspot


OBS: No meu caso, vou aplicar na WLAN, porém ela está já com uma bridge aplicada. Neste caso preciso remover ela desta bridge para adicionar em outra


22- Selecione a interface que deseja aplicar o hotspot, a bridge que você criou no passo 3 e dê OK


23- Vá até o menu RADIUS e clique no + para adicionar um servidor RADIUS


24- Em Service selecione hotspot, em Address adicione o IP 168.138.229.153 e Secret wide$123 e em Timeout 5000 e dê OK

25- Repita o passo 23 e 24, mudando o IP 168.138.226.107 


26- Agora irá faltar somente os arquivos HTML para apontar para seu domínio. Para isso, basta clicar no ícone de lápis do Ponto de Acesso desejado para Editar, clicar no botão Configurar Equipamento, e selecionar a aba Configuração Manual.


Caso precise, temos um artigo com o passo-a-passo mais detalhado:
https://suporte.mambowifi.com/support/solutions/articles/16000125491-como-encontrar-arquivos-login-html-e-alogin-html-para-mikrotik


Caso tenha dificuldades para encontrar os arquivos, contate nosso Time de Suporte através do e-mail suporte@mambowifi.com.

27- Assim que baixar os arquivos HTML (login.html e alogin.html), vá até Files e arraste estes dois arquivos para dentro da pasta hotspot


obs: Essa pasta "hotspot" pode se chamar "flash" dependendo do modelo do seu Mikrotik. 



OBS: PARA TERMINAR A CONFIGURAÇÃO, APÓS TODO O PROCEDIMENTO, VERIFIQUE ESSE MANUAL AQUI: https://suporte.mambowifi.com/support/solutions/articles/16000069116-cadastre-e-configure-seu-ponto-de-acesso


Pronto! Seu Mikrotik esta configurado e pronto para ser utilizado com o Mambo WiFi. 


Em caso de dúvida ou dificuldade, envie um e-mail para suporte@mambowifi.com