Objetivo


Este tutorial tem como objetivo corrigir o erro 404 que é exibido ao tentar conectar ao Mambo.


Pré-requisitos


Possuir um Mikrotik configurado com hotspot

Possuir acesso ao Mikrotik

Possuir internet no Mikrotik


Causas


Existem duas causas que causam este erro, sendo elas:


  1.  Caminho dos arquivos do hotspot sendo apontado para a pasta errada.
  2. Arquivos do hotspot excluídos


Resolução para a causa 1


1- Abra o Winbox e conecte ao Mikrotik


2- Vá até IP > Hotspot


3- Vá até a aba Server Profiles


Observe que o caminho dos arquivos HTML estão sendo apontados para "pasta"  e o padrão do Mikrotik é "hotspot"


4- Dê um clique duplo em cima do perfil (Que por padrão será "default")


5- Clique na opção HTML Directory e selecione "hotspot" e clique em OK


Pronto! O erro 404 já não deve mais ser apresentado.


Resolução para a causa 2


1- Abra o Winbox e conecte ao Mikrotik


2- Vá até a opção "Files" 


3- Verifique se existe uma pasta chamada hotspot e se contém arquivos dentro da mesma


Obs: Se houver bastante arquivos dentro desta pasta, realize os passos da "Causa 1"


4- Se caso não houver arquivo nenhum, ou não haver nenhuma pasta, vá até IP > Hotspot > aba Servers > Selecione seu hotspot server e clique no botão Reset HTML


5- Nesta opção pressione "Yes"


Pronto! Seu Mikrotik irá baixar os arquivos HTML padrão que precisa conter para o funcionamento do Hotspot.